Una programación deficiente en OpenSSL expuso la información personal de más de la mitad de la red.

OpenSSL es una implementación de seguridad que encripta información sensible entre tu computadora y los servidores del proveedor de servicios digitales, sea el correo electrónico, almacenamiento en la nube o hasta la banca en línea. OpenSSL no es la única implementación disponible para proteger la información, pero se estima que dos terceras partes de Internet la utilizan. ¿Cuál es el problema? Se descubrió un fallo en la programación que permite a un hacker robar la información sin dejar rastro.

No es un virus, tampoco es malware tampoco es trabajo de delincuentes cibernéticos. El bug conocido como Heartbleed (sangrado de corazón) es consecuencia de una programación deficiente en una extensión de OpenSSL llamada Heartbeat (ritmo cardiaco). Lo que permite Heartbleed es que un hacker acceda a la memoria RAM del servidor sin necesidad de contraseñas o certificados de seguridad, de forma que pueda extraer paquetes de información sin dejar rastro.

No es un problema cualquiera, especialmente si consideramos que el bug existe desde el 2011 y ha afectado a algunos sitios de importancia, como Yahoo, por ejemplo. Por otra parte, OpenSSL es la implementación principal de seguridad utilizada en Linux, incluyendo el popular Ubuntu.

El bug fue detectado por ingenieros de Google que trabajan también en la firma de seguridad Codenomicon. De acuerdo a su comunicado, fueron capaces de explotar el bug para robar información encriptada de sus servidores sin dejar rastro, por lo cual es difícil determinar si alguien descubrió el problema y lo utilizó de forma maliciosa.

Dado el alcance de OpenSSL, es muy probable que tu información haya sido expuesta en algún momento en los casi tres años que ha existido el bug, sin embargo, al momento ya se puede confirmar que los principales sitios empleados para transmitir información personal están libres del problema, incluyendo a Google, PayPal y Yahoo, por ejemplo. Utilizando la herramienta de verificación desarrollada por Codenomicon pudimos verificar que los principales bancos en México no son vulnerables a Heartbleed.

Sitios Regios ha implementado todas las actualizaciones y parches necesarios en su su infraestructura, incluyendo servidores dedicados, servidores compartidos, cloud servers y servidores virtuales. Las pruebas de vulnerabilidad han sido superadas correctamente, sin embargo, es necesario tomar medidas de seguridad adicionales a fin de proteger tu información personal y sensible.

¿Qué puedes hacer para protegerte? Puedes verificar si los sitios o portales que utilizas son vulnerables. Puedes hacerlo entrando aquí. Como siempre, es recomendable que cambies tus contraseñas, pero no solo ahora que nos enteramos del problema, sino con regularidad y empleando contraseñas seguras que incluyan números, mayúsculas y símbolos.

 



Viernes, Abril 11, 2014





« Atrás